#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<ul>(.*?)<\/ul>"
Local $sString = "sadf" & @CRLF & _
"<ul>" & @CRLF & _
"asfaskj df" & @CRLF & _
"asdflkj;asjd f" & @CRLF & _
"asdjklf jsd;" & @CRLF & _
"asdjlk;fasd f" & @CRLF & _
"asdfla;skjdf " & @CRLF & _
"asdfalk;sj f" & @CRLF & _
"uwu;akj sda s;akfjaskl; fasf" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"sdfaadf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")