using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<ul>(.*?)<\/ul>";
string input = @"sadf
<ul>
asfaskj df
asdflkj;asjd f
asdjklf jsd;
asdjlk;fasd f
asdfla;skjdf
asdfalk;sj f
uwu;akj sda s;akfjaskl; fasf
</ul>
sdfaadf";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}