$re = '/<ul>(.*?)<\/ul>/ms';
$str = 'sadf
<ul>
asfaskj df
asdflkj;asjd f
asdjklf jsd;
asdjlk;fasd f
asdfla;skjdf
asdfalk;sj f
uwu;akj sda s;akfjaskl; fasf
</ul>
sdfaadf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);