import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<ul>(.*?)<\\/ul>";
final String string = "sadf\n"
+ "<ul>\n"
+ "asfaskj df\n"
+ "asdflkj;asjd f\n"
+ "asdjklf jsd;\n"
+ "asdjlk;fasd f\n"
+ "asdfla;skjdf \n"
+ "asdfalk;sj f\n"
+ "uwu;akj sda s;akfjaskl; fasf\n"
+ "</ul>\n\n"
+ "sdfaadf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}