package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)<ul>(.*?)<\/ul>`)
var str = `sadf
<ul>
asfaskj df
asdflkj;asjd f
asdjklf jsd;
asdjlk;fasd f
asdfla;skjdf
asdfalk;sj f
uwu;akj sda s;akfjaskl; fasf
</ul>
sdfaadf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}