const regex = new RegExp('<ul>(.*?)<\\/ul>', 'gms')
const str = `sadf
<ul>
asfaskj df
asdflkj;asjd f
asdjklf jsd;
asdjlk;fasd f
asdfla;skjdf
asdfalk;sj f
uwu;akj sda s;akfjaskl; fasf
</ul>
sdfaadf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}