re = /<ul>(.*?)<\/ul>/m
str = 'sadf
<ul>
asfaskj df
asdflkj;asjd f
asdjklf jsd;
asdjlk;fasd f
asdfla;skjdf
asdfalk;sj f
uwu;akj sda s;akfjaskl; fasf
</ul>
sdfaadf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end