#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https\:\/\/\w+(-my|-admin){0,1}\.sharepoint\.com((\/\w+[_\-\.']{0,}\w+){0,}[^\.](\w+[-_'\d]{0,})){0,}$"
Local $sString = "https://sharepoint-admin.sharepoint.com/test82323''sdasd'" & @CRLF & _
"https://test.sharepoint.com" & @CRLF & _
"https://sharepoint-admin.sharepoint.com/test82323''sdasd'/testasd.1212-_" & @CRLF & _
"https://sharepoint-admin.sharepoint.com/test82323''sdasd'/testasd.1212-_"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")