package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https\:\/\/\w+(-my|-admin){0,1}\.sharepoint\.com((\/\w+[_\-\.']{0,}\w+){0,}[^\.](\w+[-_'\d]{0,})){0,}$`)
var str = `https://sharepoint-admin.sharepoint.com/test82323''sdasd'
https://test.sharepoint.com
https://sharepoint-admin.sharepoint.com/test82323''sdasd'/testasd.1212-_
https://sharepoint-admin.sharepoint.com/test82323''sdasd'/testasd.1212-_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}