using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https\:\/\/\w+(-my|-admin){0,1}\.sharepoint\.com((\/\w+[_\-\.']{0,}\w+){0,}[^\.](\w+[-_'\d]{0,})){0,}$";
string input = @"https://sharepoint-admin.sharepoint.com/test82323''sdasd'
https://test.sharepoint.com
https://sharepoint-admin.sharepoint.com/test82323''sdasd'/testasd.1212-_
https://sharepoint-admin.sharepoint.com/test82323''sdasd'/testasd.1212-_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}