// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https\:\/\/\w+(-my|-admin){0,1}\.sharepoint\.com((\/\w+[_\-\.']{0,}\w+){0,}[^\.](\w+[-_'\d]{0,})){0,}$").unwrap();
let string = "https://sharepoint-admin.sharepoint.com/test82323''sdasd'
https://test.sharepoint.com
https://sharepoint-admin.sharepoint.com/test82323''sdasd'/testasd.1212-_
https://sharepoint-admin.sharepoint.com/test82323''sdasd'/testasd.1212-_";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}