$re = '/^https\:\/\/\w+(-my|-admin){0,1}\.sharepoint\.com((\/\w+[_\-\.\']{0,}\w+){0,}[^\.](\w+[-_\'\d]{0,})){0,}$/m';
$str = 'https://sharepoint-admin.sharepoint.com/test82323\'\'sdasd\'
https://test.sharepoint.com
https://sharepoint-admin.sharepoint.com/test82323\'\'sdasd\'/testasd.1212-_
https://sharepoint-admin.sharepoint.com/test82323\'\'sdasd\'/testasd.1212-_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);