use strict;
my $str = 'https://sharepoint-admin.sharepoint.com/test82323\'\'sdasd\'
https://test.sharepoint.com
https://sharepoint-admin.sharepoint.com/test82323\'\'sdasd\'/testasd.1212-_
https://sharepoint-admin.sharepoint.com/test82323\'\'sdasd\'/testasd.1212-_';
my $regex = qr/^https\:\/\/\w+(-my|-admin){0,1}\.sharepoint\.com((\/\w+[_\-\.']{0,}\w+){0,}[^\.](\w+[-_'\d]{0,})){0,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}