# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+)\.(\d+)\.(min\.)?(css|js)$/$1.$3$4/gm;t' <<< "https://domain.com/path/to/assets/css/styles.css
https://domain.com/path/to/assets/css/styles.min.css
https://domain.com/path/to/assets/js/main.js
https://domain.com/path/to/assets/js/main.min.js
https://domain.com/path/to/assets/css/styles.1666040041.css
https://domain.com/path/to/assets/css/styles.1666040041.min.css
https://domain.com/path/to/assets/js/main.1666040041.js
https://domain.com/path/to/assets/js/main.1666040041.min.js"