import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+)\\.(\\d+)\\.(min\\.)?(css|js)$";
final String string = "https://domain.com/path/to/assets/css/styles.css\n"
+ "https://domain.com/path/to/assets/css/styles.min.css\n"
+ "https://domain.com/path/to/assets/js/main.js\n"
+ "https://domain.com/path/to/assets/js/main.min.js\n"
+ "https://domain.com/path/to/assets/css/styles.1666040041.css\n"
+ "https://domain.com/path/to/assets/css/styles.1666040041.min.css\n"
+ "https://domain.com/path/to/assets/js/main.1666040041.js\n"
+ "https://domain.com/path/to/assets/js/main.1666040041.min.js";
final String subst = "$1.$3$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}