import Foundation
let pattern = #"^(.+)\.(\d+)\.(min\.)?(css|js)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://domain.com/path/to/assets/css/styles.css
https://domain.com/path/to/assets/css/styles.min.css
https://domain.com/path/to/assets/js/main.js
https://domain.com/path/to/assets/js/main.min.js
https://domain.com/path/to/assets/css/styles.1666040041.css
https://domain.com/path/to/assets/css/styles.1666040041.min.css
https://domain.com/path/to/assets/js/main.1666040041.js
https://domain.com/path/to/assets/js/main.1666040041.min.js
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$3$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)