#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.+)\.(\d+)\.(min\.)?(css|js)$"
Local $sString = "https://domain.com/path/to/assets/css/styles.css" & @CRLF & _
"https://domain.com/path/to/assets/css/styles.min.css" & @CRLF & _
"https://domain.com/path/to/assets/js/main.js" & @CRLF & _
"https://domain.com/path/to/assets/js/main.min.js" & @CRLF & _
"https://domain.com/path/to/assets/css/styles.1666040041.css" & @CRLF & _
"https://domain.com/path/to/assets/css/styles.1666040041.min.css" & @CRLF & _
"https://domain.com/path/to/assets/js/main.1666040041.js" & @CRLF & _
"https://domain.com/path/to/assets/js/main.1666040041.min.js"
Local $sSubst = "$1.$3$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)