$re = '/^(.+)\.(\d+)\.(min\.)?(css|js)$/m';
$str = 'https://domain.com/path/to/assets/css/styles.css
https://domain.com/path/to/assets/css/styles.min.css
https://domain.com/path/to/assets/js/main.js
https://domain.com/path/to/assets/js/main.min.js
https://domain.com/path/to/assets/css/styles.1666040041.css
https://domain.com/path/to/assets/css/styles.1666040041.min.css
https://domain.com/path/to/assets/js/main.1666040041.js
https://domain.com/path/to/assets/js/main.1666040041.min.js';
$subst = "$1.$3$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;