// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+)\.(\d+)\.(min\.)?(css|js)$").unwrap();
let string = "https://domain.com/path/to/assets/css/styles.css
https://domain.com/path/to/assets/css/styles.min.css
https://domain.com/path/to/assets/js/main.js
https://domain.com/path/to/assets/js/main.min.js
https://domain.com/path/to/assets/css/styles.1666040041.css
https://domain.com/path/to/assets/css/styles.1666040041.min.css
https://domain.com/path/to/assets/js/main.1666040041.js
https://domain.com/path/to/assets/js/main.1666040041.min.js";
let substitution = "$1.$3$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}