const regex = /^(.+)\.(\d+)\.(min\.)?(css|js)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+)\\.(\\d+)\\.(min\\.)?(css|js)$', 'gm')
const str = `https://domain.com/path/to/assets/css/styles.css
https://domain.com/path/to/assets/css/styles.min.css
https://domain.com/path/to/assets/js/main.js
https://domain.com/path/to/assets/js/main.min.js
https://domain.com/path/to/assets/css/styles.1666040041.css
https://domain.com/path/to/assets/css/styles.1666040041.min.css
https://domain.com/path/to/assets/js/main.1666040041.js
https://domain.com/path/to/assets/js/main.1666040041.min.js`;
const subst = `$1.$3$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);