import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((MR|VR) ){1}((LAS|VIE|FAD) \\d{1,3}.\\d{1,3}.\\d{1,3}( )){1}(\\d{1,3}(P)){1}( DUMMY)?";
final String string = "MR LAS 1.01.01 4P\n"
+ "Prefix MR LAS 1.01.01 4P Postfix\n"
+ "Prefix MR LAS 1.01.01 4P Kürbis Postfix\n"
+ "MR LAS 1.01.01 fail 4P Postfix\n"
+ "MR LAS 1.01.01 fail 4P Kürbis Postfix\n"
+ "MR LAS 1.1.1 4P\n"
+ "MR LAS A.0.1 4P\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}