use strict;
my $str = 'MR LAS 1.01.01 4P
Prefix MR LAS 1.01.01 4P Postfix
Prefix MR LAS 1.01.01 4P Kürbis Postfix
MR LAS 1.01.01 fail 4P Postfix
MR LAS 1.01.01 fail 4P Kürbis Postfix
MR LAS 1.1.1 4P
MR LAS A.0.1 4P
';
my $regex = qr/((MR|VR) ){1}((LAS|VIE|FAD) \d{1,3}.\d{1,3}.\d{1,3}( )){1}(\d{1,3}(P)){1}( DUMMY)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}