re = /((MR|VR) ){1}((LAS|VIE|FAD) \d{1,3}.\d{1,3}.\d{1,3}( )){1}(\d{1,3}(P)){1}( DUMMY)?/m
str = 'MR LAS 1.01.01 4P
Prefix MR LAS 1.01.01 4P Postfix
Prefix MR LAS 1.01.01 4P Kürbis Postfix
MR LAS 1.01.01 fail 4P Postfix
MR LAS 1.01.01 fail 4P Kürbis Postfix
MR LAS 1.1.1 4P
MR LAS A.0.1 4P
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end