import re
regex = re.compile(r"((MR|VR) ){1}((LAS|VIE|FAD) \d{1,3}.\d{1,3}.\d{1,3}( )){1}(\d{1,3}(P)){1}( DUMMY)?", flags=re.MULTILINE)
test_str = ("MR LAS 1.01.01 4P\n"
"Prefix MR LAS 1.01.01 4P Postfix\n"
"Prefix MR LAS 1.01.01 4P Kürbis Postfix\n"
"MR LAS 1.01.01 fail 4P Postfix\n"
"MR LAS 1.01.01 fail 4P Kürbis Postfix\n"
"MR LAS 1.1.1 4P\n"
"MR LAS A.0.1 4P\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")