import Foundation
let pattern = #"((MR|VR) ){1}((LAS|VIE|FAD) \d{1,3}.\d{1,3}.\d{1,3}( )){1}(\d{1,3}(P)){1}( DUMMY)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MR LAS 1.01.01 4P
Prefix MR LAS 1.01.01 4P Postfix
Prefix MR LAS 1.01.01 4P Kürbis Postfix
MR LAS 1.01.01 fail 4P Postfix
MR LAS 1.01.01 fail 4P Kürbis Postfix
MR LAS 1.1.1 4P
MR LAS A.0.1 4P
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)