using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-z])(?=[A-Z])";
string substitution = @"\x20";
string input = @"MayTheRangeForceBeWithYou
HaroldAndKumarEscapeFromGuantanamoBay
HaroldAndKumarGoToWhiteCastle";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}