use strict;
my $str = 'MayTheRangeForceBeWithYou
HaroldAndKumarEscapeFromGuantanamoBay
HaroldAndKumarGoToWhiteCastle';
my $regex = qr~(?<=[a-z])(?=[A-Z])~mp;
my $subst = '\\x20';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";