import re
regex = re.compile(r"(?<=[a-z])(?=[A-Z])", flags=re.MULTILINE)
test_str = ("MayTheRangeForceBeWithYou\n"
"HaroldAndKumarEscapeFromGuantanamoBay\n"
"HaroldAndKumarGoToWhiteCastle")
subst = "\\x20"
result = regex.sub(subst, test_str)
if result:
print(result)