re = /(?<=[a-z])(?=[A-Z])/m
str = 'MayTheRangeForceBeWithYou
HaroldAndKumarEscapeFromGuantanamoBay
HaroldAndKumarGoToWhiteCastle'
subst = '\\x20'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result