const regex = new RegExp('(?<=[a-z])(?=[A-Z])', 'gm')
const str = `MayTheRangeForceBeWithYou
HaroldAndKumarEscapeFromGuantanamoBay
HaroldAndKumarGoToWhiteCastle`;
const subst = `\x20`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);