$re = '~(?<=[a-z])(?=[A-Z])~m';
$str = 'MayTheRangeForceBeWithYou
HaroldAndKumarEscapeFromGuantanamoBay
HaroldAndKumarGoToWhiteCastle';
$subst = "\x20";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;