# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[0-9]{7,}/<account>/gm;t' <<< "6285669871 already in history
6281246983002 not in history
08693461287 not found
6194637899 already in history "