use strict;
my $str = '6285669871 already in history
6281246983002 not in history
08693461287 not found
6194637899 already in history ';
my $regex = qr/^[0-9]{7,}/mp;
my $subst = '<account>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";