import Foundation
let pattern = #"^[0-9]{7,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
6285669871 already in history
6281246983002 not in history
08693461287 not found
6194637899 already in history
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<account>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)