using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]{7,}";
string substitution = @"<account>";
string input = @"6285669871 already in history
6281246983002 not in history
08693461287 not found
6194637899 already in history ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}