package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/www\.(?:filepicker\.io\/|filestack\.com\/)api\/file\/[\w+?&=\/]+)`)
var str = `
<img src="https://www.filepicker.io/api/file/someotherfile" />
<a href='https://www.filestack.com/api/file/anothersdf?sdf=3&dfdf=1'>link</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}