re = /(https?:\/\/www\.(?:filepicker\.io\/|filestack\.com\/)api\/file\/[\w+?&=\/]+)/m
str = '
<img src="https://www.filepicker.io/api/file/someotherfile" />
<a href=\'https://www.filestack.com/api/file/anothersdf?sdf=3&dfdf=1\'>link</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end