$re = '/(https?:\/\/www\.(?:filepicker\.io\/|filestack\.com\/)api\/file\/[\w+?&=\/]+)/m';
$str = '
<img src="https://www.filepicker.io/api/file/someotherfile" />
<a href=\'https://www.filestack.com/api/file/anothersdf?sdf=3&dfdf=1\'>link</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);