const regex = /(https?:\/\/www\.(?:filepicker\.io\/|filestack\.com\/)api\/file\/[\w+?&=\/]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/www\\.(?:filepicker\\.io\\\/|filestack\\.com\\\/)api\\\/file\\\/[\\w+?&=\\\/]+)', 'gm')
const str = `
<img src="https://www.filepicker.io/api/file/someotherfile" />
<a href='https://www.filestack.com/api/file/anothersdf?sdf=3&dfdf=1'>link</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}