import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/www\\.(?:filepicker\\.io\\/|filestack\\.com\\/)api\\/file\\/[\\w+?&=\\/]+)";
final String string = "\n"
+ "<img src=\"https://www.filepicker.io/api/file/someotherfile\" />\n"
+ "<a href='https://www.filestack.com/api/file/anothersdf?sdf=3&dfdf=1'>link</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}