#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]{4,13}\/"
Local $sString = "example.com/dies-das-jenes/best-product-with-this-id-0815/article-details" & @CRLF & _
"www.example.com/dies-das-jenes/best-product-with-this-id-4711/article-details" & @CRLF & _
"https://www.example.com/dies-das-jenes/best-product-with-this-id-2711/article-details-5541" & @CRLF & _
"https://www.example.com/dies-das-jenes/best-product-with-this-id-1234567891011/article-details-5541"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")