import re
regex = re.compile(r"[0-9]{4,13}\/", flags=re.MULTILINE)
test_str = ("example.com/dies-das-jenes/best-product-with-this-id-0815/article-details\n"
"www.example.com/dies-das-jenes/best-product-with-this-id-4711/article-details\n"
"https://www.example.com/dies-das-jenes/best-product-with-this-id-2711/article-details-5541\n"
"https://www.example.com/dies-das-jenes/best-product-with-this-id-1234567891011/article-details-5541")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")