// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]{4,13}\/").unwrap();
let string = "example.com/dies-das-jenes/best-product-with-this-id-0815/article-details
www.example.com/dies-das-jenes/best-product-with-this-id-4711/article-details
https://www.example.com/dies-das-jenes/best-product-with-this-id-2711/article-details-5541
https://www.example.com/dies-das-jenes/best-product-with-this-id-1234567891011/article-details-5541";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}