import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{4,13}\\/";
final String string = "example.com/dies-das-jenes/best-product-with-this-id-0815/article-details\n"
+ "www.example.com/dies-das-jenes/best-product-with-this-id-4711/article-details\n"
+ "https://www.example.com/dies-das-jenes/best-product-with-this-id-2711/article-details-5541\n"
+ "https://www.example.com/dies-das-jenes/best-product-with-this-id-1234567891011/article-details-5541";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}