$re = '/[0-9]{4,13}\//m';
$str = 'example.com/dies-das-jenes/best-product-with-this-id-0815/article-details
www.example.com/dies-das-jenes/best-product-with-this-id-4711/article-details
https://www.example.com/dies-das-jenes/best-product-with-this-id-2711/article-details-5541
https://www.example.com/dies-das-jenes/best-product-with-this-id-1234567891011/article-details-5541';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);