import Foundation
let pattern = #"[0-9]{4,13}\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
example.com/dies-das-jenes/best-product-with-this-id-0815/article-details
www.example.com/dies-das-jenes/best-product-with-this-id-4711/article-details
https://www.example.com/dies-das-jenes/best-product-with-this-id-2711/article-details-5541
https://www.example.com/dies-das-jenes/best-product-with-this-id-1234567891011/article-details-5541
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)