const regex = /[0-9]{4,13}\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{4,13}\\\/', 'gm')
const str = `example.com/dies-das-jenes/best-product-with-this-id-0815/article-details
www.example.com/dies-das-jenes/best-product-with-this-id-4711/article-details
https://www.example.com/dies-das-jenes/best-product-with-this-id-2711/article-details-5541
https://www.example.com/dies-das-jenes/best-product-with-this-id-1234567891011/article-details-5541`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}