# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(xi-)?(([A-Za-z0-9]+)_?)-.*/$2 or $3/gm;t' <<< "xi-AN224432_-_this_is_some_text-x10.pdf
xi-F1800X7T2P5P-blahblah-v01_00-EN.pdf
1E303S-blahblah-v01_20-EN.pdf"