$re = '/^(xi-)?(([A-Za-z0-9]+)_?)-.*/m';
$str = 'xi-AN224432_-_this_is_some_text-x10.pdf
xi-F1800X7T2P5P-blahblah-v01_00-EN.pdf
1E303S-blahblah-v01_20-EN.pdf';
$subst = "$2 or $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;