package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(xi-)?(([A-Za-z0-9]+)_?)-.*`)
var str = `xi-AN224432_-_this_is_some_text-x10.pdf
xi-F1800X7T2P5P-blahblah-v01_00-EN.pdf
1E303S-blahblah-v01_20-EN.pdf`
var substitution = "$2 or $3"
fmt.Println(re.ReplaceAllString(str, substitution))
}